Game Fishing Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
2,884 Posts
Discussion Starter · #1 ·
Picked myself up a used but really nice mid 90s 20.5ft Alumaweld with a big ol 200hp Mercury Jet tiller today! Great motor with great compression. A deal you can't pass up!

Wiring job is a mess so I'm going thu and rewiring everything.
There where wires that where hooked up to the battery that didn't even go anywhere! lol..I could not figure out why nothing worked (lights, fish finder, etc)

This boat flys! (me in the boat all bymyself) At 1/4 throttle I figure I was doin high 20s! Bumped it up to 1/2 throttle and she really moved. Openned her up all the way and don't think I have ever moved so fast in a Jet sled lol!

One problem I have is that I have a good fish finder but it wont turn on. I've completely removed the fish finder and all the wires and transduser from the boat and hooked it up to a good battery. She just wont trun on...Any ideas? There is no fuse that I can find.
 

·
Registered
Joined
·
8,509 Posts
Don't sound like such a good fishfinder to me... :D :D
 

·
Registered
Joined
·
1,988 Posts
If you get it working, fuse it. Most require a 3amp. A lowrance owners manual will tell you that you void your warranty if you do not have an in-line 3amp fuse. Good luck and congrats
 

·
Registered
Joined
·
2,884 Posts
Discussion Starter · #6 ·
It was a Lowrance X85
I bet the whole unit is gone.

Looks like I need to find 300-500 bucks (oh my taxes, wait, thats payin for my CG class) along side the road so I can go get a new fish finder(i knew I should of kept that garman out of my old boat, that was a good unit). I do have a cheapie little eagle but every time I turn it off I have to re-set the settings.
 

·
Registered
Joined
·
500 Posts
Mike I can help you with Electical problems, that is what I do for a living... Ill trade ya for a guided springer trip when its the best!

PM
Matt
 

·
Registered
Joined
·
55 Posts
How are you going to pull that thing? Did you get rid of the Ford Ranger?
 

·
Registered
Joined
·
1,360 Posts
KingFisher85 said:
Check your PM box FA

Anyone know anything about buffing Alum to make it clean and shiny again?
get this commercial chemical thing called allbright.that should work and then after if you wanted to go get some wet sand paper and it will be looking new.
 

·
Registered
Joined
·
2,884 Posts
Discussion Starter · #11 ·
I just got a good deal on a brand new Lowrance X135 or somethin like that...Sweet lookin unit. Id still, if there is a chance, would like to be able to get that x85 working.

I'm usin a big ol Chevy 2500HD DuraMax when I run trips to tow it.

I still have my Ranger and I still have my little 14ft jet.
 

·
Registered
Joined
·
513 Posts
Glad you found a new boat Mike. Do you have a website up and running yet? I will be doing some blackmouth fishing if you get a day and feel like heading up this way let me know. Mike
 

·
Registered
Joined
·
2,884 Posts
Discussion Starter · #14 ·
fishinmike
Yep, the site is up and running. We just updated it a week or two ago. cleaned it up a bit and added a few things, etc. Check the bottom of my post for a link.

I'll get a pic up soon as I get the boat all cleaned up and all the wires fixed up.
 
1 - 14 of 14 Posts
Top