Game Fishing Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
562 Posts
Discussion Starter #1
Needless to say the weather has been horrible, especially on weekends, around here and has kept most everyone off the salt water. There hasn't been a Blackmouth posting for awhile. Has anybody gotten out and how has it been? Any bait / fish showing out there?

Slabby
 

·
Registered
Joined
·
36 Posts
I have not been out this year. Weather and family keeping me inside. My read from the papers and other sources this week is that things are slowly starting to improve when weather permits. Most action has been concentrated in 8.1/8.2 in the racetrack and points North (Baby Is.) Onamac, etc. Midchannel in Area 9 has been decent and possession is just now starting to produce some bait. Also read that Brown's Bay has produced some nice fish believe it or not. I would fish that in any weather out of Edmonds.

Roche Harbor Classic this weekend, it will be interesting to see how they do up North. - RS
 

·
Registered
Joined
·
1,296 Posts
I went out Monday for about 4 hours around the racetrack and Hat island. Skunked. No shakers. Saw almost no bait. It was too windy to try to motor up north or across Posession. When I came in the checker has two fish from one boat that was out very early, and none on the next 5. I'll try it again when I dont need electric undies to keep warm.
 

·
Registered
Joined
·
1,986 Posts
I tried MA 9 double bluff and bush point last week, windy as crap as I couldnt keep a sreight line, and couldnt maintain my depth line. No shakers no nothing saw zero bait as well. BLAH. Im sticking up here in MA 7 now. As I can maybe hide from all this wind in the islands.
 

·
Registered
Joined
·
41 Posts
Went to mid channel bank from Everett this morning. Felt like it took forever to get between Possesion and PNP due to the winds. By the time I made it to lip lip it flattened and made the fishing great. Made about 9 passes with the outgoing tide, on the first pass had a hit on a g/g flasher and green/white coyote. Didn't amount to anything a few rod pumps and that was it.

Went to start the main motor and nothing dead as a door nail. Had to motor over to a local marine by kicker to fix the problem found a blown fuse going to the ignition switch. Fixed and back to fishing.

Third pass going again with the outgoing tide had a bump, went for the gear and it went crazy pulling line. Thinking I had a seal on I started trying to get as much line as possible back. All of the sudden I could see the flasher and right behind was a nice 20ish lb wild king. Beautiful fish, it took 4 runs before finally giving up and coming close enough to the boat to release. Would have been nice if it had one less fin but that is the way it goes. Still a great fight and nice fish. Safely released. Caught on g/g flasher and green/white coho killer.


Tried to take a picture but it turned out like crap. That is the way it goes when your fishing by yourself.

Staying at Port Ludlow tonight and will be back at it in the morning.
 

Attachments

1 - 8 of 8 Posts
Top